UnknownHostException while uploading an application to GAE

It is cool. Felt like weather changed drastically after the typhoon has gone.

Encountered this error while uploading an application to GAE.

Unable to update:
java.net.UnknownHostException: appengine.google.com
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(Unknown Source)
at com.sun.net.ssl.internal.ssl.BaseSSLSocketImpl.connect(Unknown Source)
at sun.net.NetworkClient.doConnect(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.protocol.https.HttpsClient.(Unknown Source)
at sun.net.www.protocol.https.HttpsClient.New(Unknown Source)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(Unknown Source)
at com.google.appengine.tools.admin.ServerConnection.connect(ServerConnection.java:338)
at com.google.appengine.tools.admin.ServerConnection.getAuthCookie(ServerConnection.java:319)
at com.google.appengine.tools.admin.ServerConnection.authenticate(ServerConnection.java:224)
at com.google.appengine.tools.admin.ServerConnection.send(ServerConnection.java:151)
at com.google.appengine.tools.admin.ServerConnection.post(ServerConnection.java:82)
at com.google.appengine.tools.admin.AppVersionUpload.send(AppVersionUpload.java:532)
at com.google.appengine.tools.admin.AppVersionUpload.beginTransaction(AppVersionUpload.java:349)
at com.google.appengine.tools.admin.AppVersionUpload.doUpload(AppVersionUpload.java:111)
at com.google.appengine.tools.admin.AppAdminImpl.update(AppAdminImpl.java:56)
at com.google.appengine.eclipse.core.proxy.AppEngineBridgeImpl.deploy(AppEngineBridgeImpl.java:271)
at com.google.appengine.eclipse.core.deploy.DeployProjectJob.runInWorkspace(DeployProjectJob.java:148)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

It was the first time I saw this exception. Because I didn’t changed any setting on Eclipse since I had uploaded my application the last time, it was very strange that I couldn’t upload it after I changed just one parameter on a class.

Then I remembered one thing. I had changed my PC to use WiFi to connect to the Internet. I had been using a wired LAN cable when I uploaded the application before.

I disabled WiFi and enabled wired connection, then I could upload the application. I wonder why I cannot upload via wireless connection.

Anyway, solving a problem with a sudden flash like this makes me happy.

Post a comment or leave a trackback: Trackback URL.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: